What(): index name missing from configuration file


#1

Hi there,
I am using MeTa installed for windows following this guide: https://meta-toolkit.org/overview-tutorial.html
Only one modification has made - just after the cloning I have used the following line:
git checkout tags/v2.4.2
I am doing this for a programming assignment in coursera: https://www.coursera.org/learn/text-mining/programming/9ywuH/programming-assignment
In this assignment I finished Task 1 and now I am struggling with task 2.
When I run : ./association …/config.toml --words 50 I get the following error:
what(): index name missing from configuration file
Any ideas - it has been 3 days and I am struggling on every single line of the code as guided in coursera. Maybe I am missing something.
During the installation when I ran ./unit-test --reporter=spec I did not get a message that everything passed.
Maybe should switch to Virtual machine and Ubuntu. I do not know.


#2

I don’t know anything in particular about your course’s assignment, so I don’t know how much help I can be here.

That error message is indicating that the index name is not present in the file .../config.toml (did you mean ../config.toml?). It would help to see the configuration file you’re trying to use.

I wonder if your configuration file is not updated for the changes in v2.3.0? In particular, as of v2.3.0 lines like

inverted-index = "some-path"
forward-index  = "some-other-path"

were unified into one line like

index = "index-path"

and the forward and inverted indexes are placed as subdirectories within that path.


#3

Hi, thanks for the reply!
This is a screen shot of the config.toml
It seems fine to me (not that I know a lot :slight_smile: ).

I am not sure how can I share more information regarding the issue, let me know what and I can share and I will happily do it.
Your support is much appreciated!


#4

Yeah, this is exactly the problem I mentioned here:

In other words, replace the two lines forward-index = "yelp-fwd" and inverted-index = "yelp-inv" with just one line index = "yelp-idx".


#5

Thanks,
well I did it but now I get the following message (instead of the results):
Segmentation fault
I got the same error when I was testing the at the end of the setup when installing MeTa:
./unit-test --reporter=spec


#6

Is there a particular reason you’re using an old version here? I suspect I might know what the problem is, which was fixed in the latest version (v3.0.2). Can you try with that version instead?


#7

Instructions in the assignment recommend using Meta 2.4.2 since otherwise the student may not be able to execute the code.
I did try with the newest meta version but got some other errors so I switched to what was suggested.
Since not sure how to proceed here I will see what I can do and write here again.
Thanks a lot for the support.


#8

Hmm… Here’s one crazy thing you could try:

git cherry-pick 8fdc6b4

That should attempt to apply this commit,which I think might be the fix for the issue you’re seeing. You’ll need to rebuild after applying that commit.

Beyond that, if you’re forced to use the old version, you might try running things within a Linux virtual machine, as this is a Windows+MINGW64-specific problem.


#9

So,
Two things solved my problems and I was able to execute everything in the assignment:

  1. Installing Virtual Box, Ubuntu and MeTa there
  2. Your comment about forward-index and inverted-index replaced by index

Thanks again for the help, much appreciated!!!