Problem with prefix = "path/to/your/tagger/folder/"


#1

I cannot seem to get the prefix folder to work. I get this error:
libc++abi.dylib: terminating with uncaught exception of type meta::util::factory<meta::analyzers::analyzer_factory, meta::analyzers::analyzer, cpptoml::table const&, cpptoml::table const&>::exception: unrecognized identifier
Abort trap: 6

Which I am not sure what it means. What I did was: downloading crf.tar.gz, extracting all the files in ~/meta/contrib/crf/ and add the following lines to my config.toml file:
[[analyzers]]
method = "ngram-pos"
ngram = 2
filter = [{type = “icu-tokenizer”}, {type = “ptb-normalizer”}]
crf-prefix = “…/contrib/crf/”

Could you please tell me what I am doing wrong? Thank you very much for your help!


#2

I found the solution, I put a ‘/’ too much. This previous post of hyori brought up to my attention that among other things I was terminating the prefix with a slash, resulting in a double slash in the location of the folder, which made it impossible to find the folder…


#3

How exactly did you solve this?
I am trying to execute the code as per the meta-toolkit.org website:
[[analyzers]]
method = "ngram-word"
ngram = 1
filter = “default-unigram-chain”

[[analyzers]]
method = "ngram-pos"
ngram = 2
filter = [{type = “icu-tokenizer”}, {type = “ptb-normalizer”}]
crf-prefix = “path/to/crf/model”

[[analyzers]]
method = "tree"
filter = [{type = “icu-tokenizer”}, {type = “ptb-normalizer”}]
features = [“skel”, “subtree”]
tagger = "path/to/greedy-tagger/model"
parser = “path/to/sr-parser/model”

I am not sure with what to replace the “path/to/…” since I am gettin the following error:
Unrecognized identified “ngram-pos”

I tried changing the crf-prefix to “…/contrib/crf/” where I have extracted the crf that I have downloaded from github but no luck.
Just for reference, due to other reasons I am using v. 2.4.2 of MeTa.


#4

did you try using the absolute path to your META installation?


#5

No, I haven’t.
Can you give an example how would that look like. I am not very good in that script.


#6

Oh, it is quite straightforward. You simply need to paste the address to the folder in which you have your metatoolkit. For example, in my linux distribution my meta repository is in ‘home’ in the ‘gitstuff’ folder. The absolute path would be like this:
/home/paolotof/gitstuff/meta


#7

Ok,
I did try it - still no luck. I will continue reading why it is not working.


#8

Perhaps the additional analyzers haven’t been registered? You’ll want something like this to be in the main() for whatever file you’re compiling.


Path to parser model compile problem