Getting a little annoying- also does not install on Ubuntu


I have not tried to install on 2 different windows machines. Without any luck. Then I installed Ubuntu on a VirtualBox and installed it here. ANd still I get the error:

/home/paul/meta/build/deps/icu-58.2/src/ExternalICU/source/i18n/digitlst.cpp:67:13: fatal error: xlocale.h: No such file or directory
 #   include <xlocale.h>
compilation terminated.
*** Failed compilation command follows: ----------------------------------------------------------
/usr/bin/c++ -ffunction-sections -fdata-sections -D_REENTRANT -DU_HAVE_ELF_H=1 -DU_ENABLE_DYLOAD=0 -DU_HAVE_ATOMIC=1 -DU_HAVE_STRTOD_L=1 -I/home/paul/meta/build/deps/icu-58.2/src/ExternalICU/source/i18n -I/home/paul/meta/build/deps/icu-58.2/src/ExternalICU/source/common -DU_ATTRIBUTE_DEPRECATED= -DU_I18N_IMPLEMENTATION -fPIC -W -Wall -pedantic -Wpointer-arith -Wwrite-strings -Wno-long-long --std=c++0x -c -o /home/paul/meta/build/deps/icu-58.2/src/ExternalICU/source/i18n/digitlst.cpp
--- ( rebuild with "make VERBOSE=1 all" to show all parameters ) --------
/home/paul/meta/build/deps/icu-58.2/src/ExternalICU/source/config/mh-linux:49: recipe for target '' failed
make[4]: *** [] Error 1
Makefile:143: recipe for target 'all-recursive' failed
make[3]: *** [all-recursive] Error 2
CMakeFiles/ExternalICU.dir/build.make:113: recipe for target 'deps/icu-58.2/src/ExternalICU-stamp/ExternalICU-build' failed
make[2]: *** [deps/icu-58.2/src/ExternalICU-stamp/ExternalICU-build] Error 2
CMakeFiles/Makefile2:67: recipe for target 'CMakeFiles/ExternalICU.dir/all' failed
make[1]: *** [CMakeFiles/ExternalICU.dir/all] Error 2
Makefile:129: recipe for target 'all' failed
make: *** [all] Error 2

There must be something wrong with the builds?

Please help, I need to get this working for an assignment and am really struggling…



It’s been a while since you asked, but I ran into the same issue recently. The solution was to make a symlink from the missing xlocale.h to locale.h

    ln -s /usr/include/locale.h /usr/include/xlocale.h

If you abandoned your efforts, don’t feel bad. I’ve tackled a number of subsequent issues after this one and am about to run out of time, I’m afraid.

source for this solution: