Error in make function during setup process in windows 10


#1

I have been trying to setup meta toolkit from 2 days and have went through all the forums but couldn’t get a possible solution.

I am working on windows 10 and have installed msys2 from msys2 website and has followed meta-toolkit setup-guide.html#windows-build-guide

I have also tried git clone --branch develop --single-branch https://github.com/meta-toolkit/meta.git
but this hasn’t worked. kindly help

The process stucks here

Unpacking C:/msys32/home/Dell/meta/build/deps/icu-63.1/src/ExternalICU/source/data/in/icudt63l.dat and generating out/tmp/icudata.lst (list of data files)
/bin/sh: -c: line 0: syntax error near unexpected token (' /bin/sh: -c: line 0:PATH=…/stubdata:…/tools/ctestfw:…/lib:$PATH …/bin/pkgdata -O …/data/icupkg.inc -q -c -s Microsoft Windows [Version 10.0.16299.125] © 2017 Microsoft Corporation. All rights reserved. C:/msys32/home/Dell/meta/build/deps/icu-63.1/src/ExternalICU-build/data>/out/build/icudt63l -d …/lib -e icudt63 -T ./out/tmp -p icudt63l -m static -r 63 -L icudt ./out/tmp/icudata.lst’
make[4]: *** [Makefile:193: packagedata] Error 1
make[3]: *** [Makefile:153: all-recursive] Error 2
make[2]: *** [CMakeFiles/ExternalICU.dir/build.make:137: deps/icu-63.1/src/ExternalICU-stamp/ExternalICU-build] Error 2
make[1]: *** [CMakeFiles/Makefile2:1374: CMakeFiles/ExternalICU.dir/all] Error 2
make: *** [Makefile:150: all] Error 2