Doing 'make' never passes 3% and give an error. Tried on two PC's


I’ve trying to setup MeTA toolkit since 2 days with no luck. I’ve followed all the steps present in the visual guide on 2 PC’s but with same error. Everything works fine until I reach the step where I just have to write “make” . It starts the process a stops and shows error at exactly 3%. Kindly help me out with this , I really want to use this and fast. Thanks.
Following image shows make command step which fails with some error I can’t understand.


Ugh. MSYS2 is kind of a moving target, so sometimes when they upgrade their GCC version stuff like this happens.

Two possible fixes:

  1. Use the develop branch, which patches things a bit to be more strict about when we enable use of std::experimental::filesystem (this will definitely work).

  2. Try passing -DMETA_HAS_EXPERIMENTAL_FILESYSTEM=OFF as an additional flag in the step where you invoke cmake (might need a clean build directory, and I’m not 100% certain if this will work).

I want to release the new version soon, so this will eventually become “just use the latest version” as the fix.


I have the same issue as OP.

I followed the procedure as in I tried this today.

Step 2. above solved the problem and allowed me to build without errors. However I get a seg fault on the first line of the unit-test script

describe [vocabulary-map]
        - it should write full blocks ... Segmentation fault


I also tried Step 1 above. I did:

git pull origin develop

and reran

git submodule update --init --recursive

then remade everything. I get the following errors:

[  1%] Performing configure step for 'ExternalICU'
configure: loading site script D:/msys64/mingw64/etc/
checking for ICU version numbers... sed: can't read D:/msys64/home/<my name>: No such file or directory
sed: can't read <my family name>/meta/build/deps/icu-60.2/src/ExternalICU/source/common/unicode/uvernum.h: No such file or directory
configure: error: Cannot determine ICU version number from uvernum.h header file 
make[2]: *** [CMakeFiles/ExternalICU.dir/build.make:109: deps/icu-60.2/src/ExternalICU-stamp/ExternalICU-configure] Error 1
make[1]: *** [CMakeFiles/Makefile2:68: CMakeFiles/ExternalICU.dir/all] Error 2
make: *** [Makefile:130: all] Error 2

Looks like it might be failing because it can’t deal with the space in the file name? The folder was made automatically by MSYS to be the same as my username on this computer, which has a space.


Any update on this? Should we wait for the next release?

Installation in Windows Error

I was able to build and run the unit test by first deleting the meta folder I already had. I got the develop branch only with:

 git clone --branch develop --single-branch

Then followed the rest of the installation guide. It failed two or three times. But after a few “make clean” commands it compiled and the unit test ran successfully.


You have no idea what I have gone through. This solution worked perfectly. Thanks!!!


I’ve followed the Setup guide and ran into the same issue yesterday.
Cloning and rebuilding the develop branch helped me out.


This helped me too. Thanks.


Your solution works for me as well, thanks a lot!