/bin/sh: patch: command not found


#1

Hi,

I’m trying to install MeTA. I got cmake to install. Then when I run make in MYS2 I get this error. May someone please help

MINGW64 ~/meta/build
$ make
[ 0%] Performing patch step for ‘ExternalICU’
/bin/sh: patch: command not found
make[2]: *** [CMakeFiles/ExternalICU.dir/build.make:102: deps/icu-58.2/src/Exter nalICU-stamp/ExternalICU-patch] Error 127
make[1]: *** [CMakeFiles/Makefile2:68: CMakeFiles/ExternalICU.dir/all] Error 2
make: *** [Makefile:128: all] Error 2


#2

I’m having the same issue. Tried it on Windows 10 and Windows 7 with the same end result. This does not help you, of course. I googled this a bit and couldn’t immediately find a solution, unfortunately.


#3

Thanks, Hopefully someone may have solution


#4

Hmm…

Maybe

pacman -S patch

and try again?


#5

Wow thanks. That worked.

How did you figure that out? Is there a tutorial I may refer to?


#6

Just experience. The error message is saying that the patch command wasn’t found, so it’s reasonable to suspect that it’s provided by a package with a similar name. Since pacman is the package manager used within MSYS2, and you install packages with pacman -S $name_of_package, that was my guess.

I will update the setup guide to include installing patch so people hopefully won’t have this issue in the future.